Note: This post is auto-generated by ChatGPT based on my recent experience while trying to resolve the issue. The information here is for reference only and may not be entirely accurate. You are welcome to add your comments below.
If you need to run a scheduled task on your Mac—even when it’s asleep—you’ll quickly find that cron doesn’t wake up the computer by itself. This post covers how to schedule a cron job at 7 AM on macOS and ensure it runs reliably, even if the Mac is sleeping.
1️⃣ Setting Up a Cron Job
macOS still supports cron, although Apple prefers launchd for scheduling tasks. To add a cron job, first, open Terminal and run:
crontab -e
This will open your crontab file for editing. Add the following line to run a script at 7:00 AM daily:
0 7 * * * /Users/adam/Projects/ss-db/restore.sh
Make sure your script is executable:
chmod +x /Users/adam/Projects/ss-db/restore.sh
✅ Does Cron Run When the Mac is Asleep?
No. If your Mac is asleep at 7 AM, cron will not run. It only executes jobs when the system is awake.
2️⃣ Using pmset to Wake the Mac
To ensure your Mac wakes up before running the cron job, schedule a wake event using:
sudo pmset schedule wakeorpoweron "07:00:00"
This tells macOS to wake up at 7:00 AM every day, ensuring that the cron job can run.
Checking Scheduled Wake Events
Verify the scheduled wake-up with:
pmset -g sched
3️⃣ Using launchd Instead of Cron
Since macOS favors launchd over cron, another approach is to create a LaunchAgent or LaunchDaemon.
Create a LaunchAgent (~/Library/LaunchAgents/com.adam.restoreDB.plist)
1. Open Terminal and create the file:
nano ~/Library/LaunchAgents/com.adam.restoreDB.plist
2. Add the following XML:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>com.adam.restoreDB</string>
<key>ProgramArguments</key>
<array>
<string>/Users/adam/Projects/ss-db/restore.sh</string>
</array>
<key>StartCalendarInterval</key>
<dict>
<key>Hour</key>
<integer>7</integer>
<key>Minute</key>
<integer>0</integer>
</dict>
<key>WakeSystem</key>
<true/>
</dict>
</plist>
3. Load the job into launchctl:
launchctl load ~/Library/LaunchAgents/com.adam.restoreDB.plist
4. To run the job immediately:
launchctl start com.adam.restoreDB
5. To unload the job:
launchctl unload ~/Library/LaunchAgents/com.adam.restoreDB.plist
✅ Why Use launchd?
• It supports waking up the system (WakeSystem).
• It’s more reliable than cron on modern macOS versions.
• No need to manually set pmset wake timers.
4️⃣ Checking Logs & Debugging
If the script doesn’t run:
1. Check cron logs:
tail -f /var/log/system.log
or:
grep cron /var/log/system.log
2. Check LaunchAgent logs:
log show --predicate 'subsystem == "com.apple.launchd"' --info --last 10m
3. Manually test the script:
/Users/adam/Projects/ss-db/restore.sh
📌 Final Thoughts
Which Method Should You Use?
Feature | Cron | pmset + Cron | launchd |
---|---|---|---|
Runs on schedule | ✅ | ✅ | ✅ |
Works if Mac is asleep | ❌ | ✅ | ✅ |
Logs & Debugging | Limited | Limited | Better |
Apple-Recommended | ❌ | ❌ | ✅ |
If your Mac is always awake at 7 AM, cron is enough.
If your Mac sleeps, use pmset + cron or launchd.
For Apple’s recommended approach, launchd is the best.
🚀 TL;DR
✅ To run a cron job at 7 AM, even if your Mac is asleep:
• Use pmset to wake the Mac before execution.
• Or, use launchd (WakeSystem key) for a more reliable setup.
Got questions? Drop them in the comments! 🚀